Urban Airship System Status
Delays in Named User Registration Events and Increased 5xx Errors
Incident Report for Urban Airship
Postmortem

Between 11:47 PT and 18:51 PT 8 February 2018, we experienced an issue that resulted in delays in Named User Registration Events of over 60 minutes. Events delayed include association and dissociation of devices to Named Users and tag changes to Named Users. Customers may have also experienced 5xx errors and timeouts from named user API and channel listing API endpoints, and noticed Connect event lag of over 4 hours at some points. Engineering addressed the problem and no data received by our system was lost.

Posted 6 months ago. Feb 14, 2018 - 07:19 PST

Resolved
We have resolved the issue that resulted in delays in Named User Registration Events, Connect Events, and increased Channel Listing API Errors.

If you have any additional questions or concerns, please contact Urban Airship Technical Support at https://support.urbanairship.com/
Posted 6 months ago. Feb 08, 2018 - 19:35 PST
Update
We have resolved the issue that resulted in delays in Named User Registration Events. These include association and dissociation of devices to Named Users, as well as tag changes on Named Users. All events were processed and no data was lost.

Users may continue to experience 5xx errors when accessing the Channel Listing API. Connect customers may see latency in streams reporting custom events, state changes, sends, Message Center, and device events.
Posted 6 months ago. Feb 08, 2018 - 18:03 PST
Identified
We have identified an issue that is resulting in delays in Named User Registration Events. These include association and dissociation of devices to Named Users, as well as tag changes on Named Users. You may also see an increase in 5xx errors returned when making requests to the Named User API.”
Posted 6 months ago. Feb 08, 2018 - 13:48 PST
Investigating
We have identified an issue that is resulting in delays in Named User Registration Events. These include association and dissociation of devices to Named Users, as well as tag changes on Named Users.

Our Operations and Engineering teams are actively working on the issue.

If you have any additional questions or concerns, please contact Urban Airship Technical Support at https://support.urbanairship.com/
Posted 6 months ago. Feb 08, 2018 - 12:06 PST
This incident affected: Engage (API, Web Dashboard (go.urbanairship.com)).